Skip to Content

GCC on FC4

mborn's picture

Assalamo Alikum, How are you all?

Well, gcc on FC4 does not include g77 (nor f77) and they included instead gfortran which is not yet matured enough to be fully used instead of g77 (or f77). g77 is vital for my codes. I could not use pgf77 not Intel fortran instead. do you have suggestions? and is there anyone here aware of the news developments on gcc4? Did they add g77 back to it? I have tried with all means to contact them but to no avail. I have also tried to file a bug report, for which I had nothing in return.

Thanks

Max

Conceptor's picture

check this

from yum info compat-gcc-32-g77 Summary: Fortran 77 support for compatibility compiler Description: The compat-gcc-32-g77 package provides support for compiling Fortran 77 programs with the GNU Compiler Collection.


Diaa Radwan

mborn's picture

Assalamo Alikum, I have

Assalamo Alikum,

I have already installed this package, but I was faced with an error message telling me that "libg2c" is not there. This is a library for linking between C and fortran, as you surely know.

Well, I will try again, but I wonder about gcc4 and above, did they include g77? I hope they did.

PS. I have been in their website but could not find a clue about this point.

Thank you for ur time,

M B

mborn's picture

Any other

Any other solutions?

Thank you for ur time,

M B

Conceptor's picture

did you use yum? Diaa

did you use yum?


Diaa Radwan

mborn's picture

yes, exactly as you

yes, exactly as you said.

Thank you for ur time,

M B

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.


Dr. Radut | forum